java.io.IOException

Cannot run program "___REMOVE___/bin/avrdude": CreateProcess error=2, El sistema no puede hallar el archivo especificado

Samebug tips1

This is a bug in some versions of the Arduino IDE. Try updating to the version 1.6.12 or further.

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web16414

  • via GitHub by jmandion
    , 5 months ago
    Cannot run program "___REMOVE___/bin/avrdude": CreateProcess error=2, El sistema no puede hallar el archivo especificado
  • via Oracle Community by 843802, 1 year ago
    Cannot run program "C:\Archivos de programa\Java\jre1.6.0_01\bin\javac": CreateProcess error=2, El sistema no puede hallar el archivo especificado
  • Cannot run program “javac.exe”: CreateProcess error=2, El sistema no puede encontrar el archivo especificado
  • Stack trace

    • java.io.IOException: Cannot run program "___REMOVE___/bin/avrdude": CreateProcess error=2, El sistema no puede hallar el archivo especificado at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048) at processing.app.helpers.ProcessUtils.exec(ProcessUtils.java:26) at cc.arduino.packages.Uploader.executeUploadCommand(Uploader.java:129) at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:207) at cc.arduino.UploaderUtils.upload(UploaderUtils.java:78) at processing.app.SketchController.upload(SketchController.java:709) at processing.app.SketchController.exportApplet(SketchController.java:682) at processing.app.Editor$DefaultExportHandler.run(Editor.java:2190) at java.lang.Thread.run(Thread.java:745) Caused by: java.io.IOException: CreateProcess error=2, El sistema no puede hallar el archivo especificado at java.lang.ProcessImpl.create(Native Method) at java.lang.ProcessImpl.<init>(ProcessImpl.java:386) at java.lang.ProcessImpl.start(ProcessImpl.java:137) at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029) ... 8 more

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 11 months ago
    Unknown user
    Once, 11 months ago
    Unknown user
    Once, 11 months ago
    Unknown user
    2 times, 11 months ago
    Unknown user
    2 times, 11 months ago
    161 more bugmates