org.osgi.framework.BundleException: Unresolved constraint in bundle xxx.core [446]: Unable to resolve 446.1: missing requirement [446.1] osgi.wiring.package; (&(osgi.wiring.package=xxx.acs.commons.dispatcher)(version>=1.0.0)(!(version>=2.0.0)))

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via Stack Overflow by Ruchi
, 10 months ago
Unresolved constraint in bundle xxx.core [446]: Unable to resolve 446.1: missing requirement [446.1] osgi.wiring.package; (&(osgi.wiring.package=xxx.acs.commons.dispatcher)(version>=1.0.0)(!(version>=2.0.0)))
via GitHub by sneumann
, 1 year ago
Unresolved constraint in bundle org.isatools.plugins.metabolights.metabolomics [1]: Unable to resolve 1.0: missing requirement [1.0] osgi.wiring.package; (&(osgi.wiring.package=javax.xml.namespace)(version>=1.0.0)(!(version>=2.0.0)))
via servicemix-users by Michael, 1 year ago
Unresolved constraint in bundle org.apache.karaf.features.obr [10]: Unable to resolve 10.0: missing requirement [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.blueprint)(version>=1.0.0)(!(version>=2.0.0)))
via servicemix-users by Michael, 1 year ago
Unresolved constraint in bundle org.apache.karaf.features.obr [10]: Unable to resolve 10.0: missing requirement [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.blueprint)(version>=1.0.0)(!(version>=2.0.0)))
via GitHub by pires
, 2 years ago
Unresolved constraint in bundle org.apache.aries.proxy.api [7]: Unable to resolve 7.0: missing requirement [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.aries.util.nls)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve
via gmane.org by Unknown author, 1 year ago
Unresolved constraint in bundle org.apache.aries.proxy.api [9]: Unable to resolve 9.0: missing requirement [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.aries.util.nls)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve
org.osgi.framework.BundleException: Unresolved constraint in bundle xxx.core [446]: Unable to resolve 446.1: missing requirement [446.1] osgi.wiring.package; (&(osgi.wiring.package=xxx.acs.commons.dispatcher)(version>=1.0.0)(!(version>=2.0.0)))
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4095)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2114)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1368)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.lang.Thread.run(Thread.java:745)

Users with the same issue

28 times, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 2 months ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.