com.wingman.client.plugin.exceptions.PluginLoadingException: GroundItems loading error: The expected dependency plugin DevUtils of minimum version 1.0.2 is not installed.

GitHub | Woolba | 2 weeks ago
tip
Do you know that we can give you better hits? Get more relevant results from Samebug’s stack trace search.
  1. 0

    Plugins not working/loading

    GitHub | 2 weeks ago | Woolba
    com.wingman.client.plugin.exceptions.PluginLoadingException: GroundItems loading error: The expected dependency plugin DevUtils of minimum version 1.0.2 is not installed.
  2. 0

    Problem with directions in google-api-java-client

    GitHub | 2 years ago | GoogleCodeExporter
    com.intellij.openapi.externalSystem.model.ExternalSystemException: You are using an old, unsupported version of Gradle. Please use version 1.8 or greater. and fails to import. I've tried: a) Clicking "Use auto-import" which uses the built-in gradle 1.8 from android-studio I think. That fails, saying "Project is using an old version of the Android Gradle plug-in. The minimum supported version is 0.6.1." b) Installing gradle 1.8 (the same way as gradle 1.6 was installed) and pointing to it. Same error as above. c) Installing gradle 1.9 (same as above) and pointing to it. That now says "Gradle version 1.6 is required. Current version is 1.9" (?!) I've also tried changing the plugin version via the classpath in the top level build.gradle file: --- a/build.gradle Fri Sep 27 14:46:11 2013 +0100 +++ b/build.gradle Fri Jan 03 12:50:18 2014 -0800 @@ -4,7 +4,7 @@ } dependencies { - classpath 'com.android.tools.build:gradle:0.5.+' + classpath 'com.android.tools.build:gradle:0.7.0' } } This then says "Gradle version 1.9 is required. Current version is 1.8. If using the gradle wrapper, try editing the distributionUrl in .../google-api-java-client-samples/gradle/wrapper/gradle-wrapper.properties to gradle-1.9-all.zip" That gradle/wrapper directory does not exist. Finally, if I switch to using both gradle-1.9 and changing the plugin classpath as above, I get this error "Cause: java.util.ArrayList cannot be cast to java.util.Map" which appears to happen with this stack:
  3. 0

    Problem with directions in google-api-java-client

    GitHub | 2 years ago | wonderfly
    com.intellij.openapi.externalSystem.model.ExternalSystemException: You are using an old, unsupported version of Gradle. Please use version 1.8 or greater. and fails to import. I've tried: a) Clicking "Use auto-import" which uses the built-in gradle 1.8 from android-studio I think. That fails, saying "Project is using an old version of the Android Gradle plug-in. The minimum supported version is 0.6.1." b) Installing gradle 1.8 (the same way as gradle 1.6 was installed) and pointing to it. Same error as above. c) Installing gradle 1.9 (same as above) and pointing to it. That now says "Gradle version 1.6 is required. Current version is 1.9" (?!) I've also tried changing the plugin version via the classpath in the top level build.gradle file: --- a/build.gradle Fri Sep 27 14:46:11 2013 +0100 +++ b/build.gradle Fri Jan 03 12:50:18 2014 -0800 @@ -4,7 +4,7 @@ } dependencies { - classpath 'com.android.tools.build:gradle:0.5.+' + classpath 'com.android.tools.build:gradle:0.7.0' } } This then says "Gradle version 1.9 is required. Current version is 1.8. If using the gradle wrapper, try editing the distributionUrl in .../google-api-java-client-samples/gradle/wrapper/gradle-wrapper.properties to gradle-1.9-all.zip" That gradle/wrapper directory does not exist. Finally, if I switch to using both gradle-1.9 and changing the plugin classpath as above, I get this error "Cause: java.util.ArrayList cannot be cast to java.util.Map" which appears to happen with this stack:
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Problem with directions in google-api-java-client

    GitHub | 2 years ago | GoogleCodeExporter
    com.intellij.openapi.externalSystem.model.ExternalSystemException: You are using an old, unsupported version of Gradle. Please use version 1.8 or greater. and fails to import. I've tried: a) Clicking "Use auto-import" which uses the built-in gradle 1.8 from android-studio I think. That fails, saying "Project is using an old version of the Android Gradle plug-in. The minimum supported version is 0.6.1." b) Installing gradle 1.8 (the same way as gradle 1.6 was installed) and pointing to it. Same error as above. c) Installing gradle 1.9 (same as above) and pointing to it. That now says "Gradle version 1.6 is required. Current version is 1.9" (?!) I've also tried changing the plugin version via the classpath in the top level build.gradle file: --- a/build.gradle Fri Sep 27 14:46:11 2013 +0100 +++ b/build.gradle Fri Jan 03 12:50:18 2014 -0800 @@ -4,7 +4,7 @@ } dependencies { - classpath 'com.android.tools.build:gradle:0.5.+' + classpath 'com.android.tools.build:gradle:0.7.0' } } This then says "Gradle version 1.9 is required. Current version is 1.8. If using the gradle wrapper, try editing the distributionUrl in .../google-api-java-client-samples/gradle/wrapper/gradle-wrapper.properties to gradle-1.9-all.zip" That gradle/wrapper directory does not exist. Finally, if I switch to using both gradle-1.9 and changing the plugin classpath as above, I get this error "Cause: java.util.ArrayList cannot be cast to java.util.Map" which appears to happen with this stack:

    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. com.wingman.client.plugin.exceptions.PluginLoadingException

      GroundItems loading error: The expected dependency plugin DevUtils of minimum version 1.0.2 is not installed.

      at com.wingman.client.plugin.PluginManager.parsePluginDependencies()
    2. com.wingman.client
      PluginManager.parsePluginDependencies
      1. com.wingman.client.plugin.PluginManager.parsePluginDependencies(PluginManager.java:150)
      1 frame