java.net.BindException

Address already in use: bind


Samebug tips3

It might be that there's another process connecting to the same port you're trying to use, try to kill it or change the connection port.

Try changing the port in core-site.xml from 9000 to 9001 as it seems port 9000 doesn't work.

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.


Solutions on the web4334

Solution icon of coderanch
Address already in use: bind

Solution icon of github
via GitHub by Cashe18
, 11 months ago
Address already in use: bind

Solution icon of github
via GitHub by Vshuds
, 11 months ago
Address already in use: bind

Solution icon of github
via GitHub by Valdo197
, 7 months ago
Address already in use: bind

Solution icon of github
Address already in use: bind

Solution icon of github
via GitHub by lukaszx0
, 7 months ago
Address already in use: bind

Solution icon of github
via GitHub by ezekel
, 1 year ago
Address already in use: bind

Solution icon of googlegroups
via Google Groups by Zolf, 1 year ago
Address already in use: bind

Solution icon of googlegroups
via Google Groups by Muthukumaran Kothandaraman, 1 year ago
Address already in use: bind

Solution icon of googlegroups
via Google Groups by Félix Roberto Aballí Morell, 2 months ago
Address already in use: bind

Stack trace

  • java.net.BindException: Address already in use: bind at sun.nio.ch.Net.bind0(Native Method) at sun.nio.ch.Net.bind(Unknown Source) at sun.nio.ch.Net.bind(Unknown Source) at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source) at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source) at org.seleniumhq.jetty9.server.ServerConnector.open(ServerConnector.java:321) at org.seleniumhq.jetty9.server.AbstractNetworkConnector.doStart(AbstractNetworkConnector.java:80) at org.seleniumhq.jetty9.server.ServerConnector.doStart(ServerConnector.java:236) at org.seleniumhq.jetty9.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68) at org.seleniumhq.jetty9.server.Server.doStart(Server.java:366) at org.seleniumhq.jetty9.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68) at org.openqa.selenium.remote.server.SeleniumServer.boot(SeleniumServer.java:147) at org.openqa.grid.selenium.GridLauncherV3$1.launch(GridLauncherV3.java:229) at org.openqa.grid.selenium.GridLauncherV3.main(GridLauncherV3.java:91)

Write tip

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
2 times, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
150 more bugmates