com.typesafe.config.ConfigException$Missing: No configuration setting found for key 'akka.version'


Solutions on the web

Solution icon of github
via GitHub by quintinali
, 8 months ago
No configuration setting found for key 'akka.version'

Solution icon of googlegroups
via Google Groups by Sergey Malov, 1 year ago
No configuration setting found for key 'akka.version'

Solution icon of apache
via spark-dev by Lochana Menikarachchi, 1 year ago
No configuration setting found for key 'akka.version'

Solution icon of github
via GitHub by karanjeets
, 11 months ago
No configuration setting found for key 'akka.version'

Solution icon of stackoverflow
No configuration setting found for key 'akka.version'

Solution icon of stackoverflow
No configuration setting found for key 'akka.version'

Solution icon of web
No configuration setting found for key 'akka.version'

Solution icon of googlegroups
via Google Groups by Nathan, 1 year ago
No configuration setting found for key 'akka.version'

Solution icon of stackoverflow
via Stack Overflow by Will I Am
, 1 year ago
No configuration setting found for key 'akka.version'

Solution icon of stackoverflow
No configuration setting found for key 'akka.version'

Stack trace

com.typesafe.config.ConfigException$Missing: No configuration setting found for key 'akka.version'
	at com.typesafe.config.impl.SimpleConfig.findKey(SimpleConfig.java:124)
	at com.typesafe.config.impl.SimpleConfig.find(SimpleConfig.java:145)
	at com.typesafe.config.impl.SimpleConfig.find(SimpleConfig.java:151)
	at com.typesafe.config.impl.SimpleConfig.find(SimpleConfig.java:159)
	at com.typesafe.config.impl.SimpleConfig.find(SimpleConfig.java:164)
	at com.typesafe.config.impl.SimpleConfig.getString(SimpleConfig.java:206)
	at akka.actor.ActorSystem$Settings.<init>(ActorSystem.scala:169)
	at akka.actor.ActorSystemImpl.<init>(ActorSystem.scala:505)
	at akka.actor.ActorSystem$.apply(ActorSystem.scala:142)
	at akka.actor.ActorSystem$.apply(ActorSystem.scala:119)
	at org.apache.spark.util.AkkaUtils$.org$apache$spark$util$AkkaUtils$$doCreateActorSystem(AkkaUtils.scala:121)
	at org.apache.spark.util.AkkaUtils$$anonfun$1.apply(AkkaUtils.scala:53)
	at org.apache.spark.util.AkkaUtils$$anonfun$1.apply(AkkaUtils.scala:52)
	at org.apache.spark.util.Utils$$anonfun$startServiceOnPort$1.apply$mcVI$sp(Utils.scala:2024)
	at scala.collection.immutable.Range.foreach$mVc$sp(Range.scala:166)
	at org.apache.spark.util.Utils$.startServiceOnPort(Utils.scala:2015)
	at org.apache.spark.util.AkkaUtils$.createActorSystem(AkkaUtils.scala:55)
	at org.apache.spark.SparkEnv$.create(SparkEnv.scala:266)
	at org.apache.spark.SparkEnv$.createDriverEnv(SparkEnv.scala:193)
	at org.apache.spark.SparkContext.createSparkEnv(SparkContext.scala:288)
	at org.apache.spark.SparkContext.<init>(SparkContext.scala:457)
	at org.apache.spark.api.java.JavaSparkContext.<init>(JavaSparkContext.scala:59)
	at esiptestbed.mudrod.driver.SparkDriver.<init>(SparkDriver.java:34)
	at esiptestbed.mudrod.main.MudrodEngine.main(MudrodEngine.java:337)

Write tip

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 2 years ago
Samebug visitor profile picture
Unknown user
Once, 3 months ago
Samebug visitor profile picture
Unknown user
Once, 3 months ago
Samebug visitor profile picture
Unknown user
Once, 3 months ago
23 more bugmates