java.io.IOException: failure to login: No LoginModules configured for hadoop_simple


Solutions on the web

Solution icon of stackoverflow
failure to login: No LoginModules configured for hadoop_simple

Solution icon of stackoverflow
failure to login

Solution icon of github
failure to login

Solution icon of stackoverflow
failure to login

Solution icon of stackoverflow
via Stack Overflow by Tim Nguyen
, 8 months ago
failure to login

Solution icon of stackoverflow
failure to login

Solution icon of web
via nabble.com by Unknown author, 1 year ago
failure to login

Solution icon of web
via mapr.com by Unknown author, 6 months ago
failure to login: Unable to obtain MapR credentials

Stack trace

java.io.IOException: failure to login: No LoginModules configured for hadoop_simple
	at org.apache.hadoop.security.UserGroupInformation.loginUserFromSubject(UserGroupInformation.java:724)
	at org.apache.hadoop.security.UserGroupInformation.getLoginUser(UserGroupInformation.java:676)
	at org.apache.hadoop.security.UserGroupInformation.getCurrentUser(UserGroupInformation.java:560)
	at org.apache.hadoop.fs.FileSystem$Cache$Key.<init>(FileSystem.java:2784)
	at org.apache.hadoop.fs.FileSystem$Cache$Key.<init>(FileSystem.java:2776)
	at org.apache.hadoop.fs.FileSystem$Cache.get(FileSystem.java:2642)
	at org.apache.hadoop.fs.FileSystem.get(FileSystem.java:404)
	at org.apache.hadoop.fs.FileSystem.getLocal(FileSystem.java:375)
	at org.apache.hadoop.util.GenericOptionsParser.validateFiles(GenericOptionsParser.java:392)
	at org.apache.hadoop.util.GenericOptionsParser.processGeneralOptions(GenericOptionsParser.java:288)
	at org.apache.hadoop.util.GenericOptionsParser.parseGeneralOptions(GenericOptionsParser.java:479)
	at org.apache.hadoop.util.GenericOptionsParser.<init>(GenericOptionsParser.java:170)
	at org.apache.hadoop.util.GenericOptionsParser.<init>(GenericOptionsParser.java:153)
	at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:64)
	at elt_3_0.hbase_customertable_0_1.Hbase_customertable.runJobInTOS(Hbase_customertable.java:38664)
	at elt_3_0.hbase_customertable_0_1.Hbase_customertable.main(Hbase_customertable.java:38642)
Caused by: javax.security.auth.login.LoginException: No LoginModules configured for hadoop_simple
	at javax.security.auth.login.LoginContext.init(LoginContext.java:272)
	at javax.security.auth.login.LoginContext.<init>(LoginContext.java:389)
	at org.apache.hadoop.security.UserGroupInformation.newLoginContext(UserGroupInformation.java:450)
	at org.apache.hadoop.security.UserGroupInformation.loginUserFromSubject(UserGroupInformation.java:696)
	... 15 more

Write tip

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 5 months ago
Samebug visitor profile picture
Unknown user
Once, 10 months ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
1 more bugmates