java.lang.UnsupportedClassVersionError: org/elasticsearch/bootstrap/Elasticsearch : Unsupported major.minor version 52.0

Stack Overflow | benroth | 2 months ago
tip
Do you find the tips below useful? Click on the to mark them and say thanks to rafael . Or join the community to write better ones.
  1. 0
    samebug tip
    From v1.2 and beyond, ElasticSearch doesn't support Java 6 anymore, consider upgrading to Java 7 or any newer version or getting an older version of ElasticSearch.
  2. 0

    Elasticsearch: Unsupported major.minor version 52.0

    Stack Overflow | 2 months ago | benroth
    java.lang.UnsupportedClassVersionError: org/elasticsearch/bootstrap/Elasticsearch : Unsupported major.minor version 52.0
  3. 0

    GitHub comment 1#99593074

    GitHub | 2 years ago | megastef
    org.elasticsearch.ElasticsearchException: Failed to load plugin class [io.crate.plugin.AutoCompletePlugin]
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    GitHub comment 12#39972020

    GitHub | 3 years ago | gmercey
    org.elasticsearch.ElasticsearchException: Failed to load plugin class [org.xbib.elasticsearch.plugin.langdetect.LangdetectPlugin]
  6. 0

    Unsupported major.minor version 52.0

    GitHub | 2 years ago | cyanglee
    org.elasticsearch.ElasticsearchException: Failed to load plugin class [org.codelibs.elasticsearch.taste.TastePlugin]

    2 unregistered visitors
    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. java.lang.UnsupportedClassVersionError

      org/elasticsearch/bootstrap/Elasticsearch : Unsupported major.minor version 52.0

      at java.lang.ClassLoader.defineClass1()
    2. Java RT
      ClassLoader.defineClass1
      1. java.lang.ClassLoader.defineClass1(Native Method)
      1 frame