Pattern selector

Most relevant patterns first. Most helpful ones displayed. Click here to show all.

  1. ClassLoader.loadClass() has thrown an UnsupportedClassVersionError
    Java Runtime
    205
    436
    46
  2. ClassLoader.defineClass() has thrown an UnsupportedClassVersionError
    Java Runtime
    433
    769
    233

Your stack trace compared to the selected pattern

Jump to solutionsExpand frames
java.lang.UnsupportedClassVersionError: com/netflix/servo/tag/Tags : Unsupported major.minor version 52.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)
6 frames hidden

Solution

Shane Rogers11 months ago

This exception occurs when using an older version of java. Mainly when trying to run a jar compiled with a newer Java version in an older Java version. We can avoid this issue by executing the jar in the same version which it was compiled.

Check the source of this solution for more info

External results for this pattern (10)

  1. flikvia GitHub2 days ago
    org/openqa/grid/selenium/GridLauncherV3 : Unsupported major.minor version 52.0
    Show stack trace
  2. scroixvia GitHub2 days ago
    org/nodel/jyhost/Launch : Unsupported major.minor version 52.0 ost/Launch : Unsupported major.minor version 52.0
    Show stack trace
  3. beornharrisvia GitHub4 days ago
    com/uc4/api/InvalidUC4NameException : Unsupported major.minor version 52.0
    Show stack trace
  4. phobrovia GitHub4 days ago
    application/Main : Unsupported major.minor version 52.0
    Show stack trace
  5. marudyvia GitHub6 days ago
    cloudExplorer/CloudExplorer has been compiled by a more recent version of the Java Runtime (class file version 54.0), this version of the Java Runtime only recognizes class file versions up to 52.0
    Show stack trace
  6. daki0709via GitHub1 week ago
    java.lang.UnsupportedClassVersionError: fr/klemms/halloweeninvasion/Halloween : Unsupported major.minor version 52.0
    Show stack trace
  7. Martin Doreyvia Google Groups1 week ago
    Bad version number in .class file
    Show stack trace
  8. Linn Jensenvia Google Groups1 week ago
    gov/nasa/jpf/tool/RunJPF : Unsupported major.minor version 52.0
    Show stack trace
  9. maghervia Google Groups1 week ago
    MainApp : Unsupported major.minor version 52.0
    Show stack trace
  10. yacchin1205via GitHub1 week ago
    com/google/cloud/hadoop/fs/gcs/GoogleHadoopFileSystem : Unsupported major.minor version 52.0
    Show stack trace