org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.proxy.api [8]: Unable to resolve 8.0: missing requirement [8.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.aries.util.nls)(version=1.0.0)(!(version=2.0.0))) [caused by: Unable to resolve 11.0: missing requirement [11.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.5.0)(!(version=2.0.0)))]

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via hivmr.com by Unknown author, 1 year ago
Unresolved constraint in bundle org.apache.aries.proxy.api [8]: Unable to resolve 8.0: missing requirement [8.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.aries.util.nls)(version=1.0.0)(!(version=2.0.0))) [caused by: Unable to resolve
via gmane.org by Unknown author, 1 year ago
Unresolved constraint in bundle org.apache.aries.proxy.api [9]: Unable to resolve 9.0: missing requirement [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.aries.util.nls)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve
via GitHub by pires
, 2 years ago
Unresolved constraint in bundle org.apache.aries.proxy.impl [11]: Unable to resolve 11.0: missing requirement [11.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.aries.proxy)(version>=1.0.0)(!(version>=1.1.0))) [caused by: Unable to
via Google Groups by Unknown author, 5 months ago
Unresolved constraint in bundle org.apache.aries.proxy [9]: Unable to resolve 9.0: m issing requirement [9.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.aries.util)(version>=0.3.0)(!(version>=1 .0.0))) [caused by: Unable to resolve
via Google Groups by Richard-Clayton, 6 months ago
Unresolved constraint in bundle com.rabbitmq.client [11]: Unable to resolve 11.0: missing requirement [11.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.commons.io)(version>=1.4.0)(!(version>=2.0.0)))
via Java.net JIRA by arungupta, 1 year ago
Unresolved constraint in bundle org.glassfish.hk2.api [117]: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]
org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.proxy.api [8]: Unable to resolve 8.0: missing requirement [8.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.aries.util.nls)(version=1.0.0)(!(version=2.0.0))) [caused by: Unable to resolve 11.0: missing requirement [11.0] osgi.wiring.package; ((osgi.wiring.package=org.osgi.framework)(version=1.5.0)(!(version=2.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4225)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2063)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1317)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
at java.lang.Thread.run(Thread.java:745)

Users with the same issue

28 times, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 2 months ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.