org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.obr [10]: Unable to resolve 10.0: missing requirement [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.blueprint)(version>=1.0.0)(!(version>=2.0.0)))

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via servicemix-users by Michael, 1 year ago
Unresolved constraint in bundle org.apache.karaf.features.obr [10]: Unable to resolve 10.0: missing requirement [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.blueprint)(version>=1.0.0)(!(version>=2.0.0)))
via servicemix-users by Michael, 1 year ago
Unresolved constraint in bundle org.apache.karaf.features.obr [10]: Unable to resolve 10.0: missing requirement [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.blueprint)(version>=1.0.0)(!(version>=2.0.0)))
via GitHub by pires
, 2 years ago
Unresolved constraint in bundle org.apache.aries.util [10]: Unable to resolve 10.0: missing requirement [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0)(!(version>=2.0.0)))
via GitHub by csnyulas
, 1 year ago
Unresolved constraint in bundle it.unibz.krdb.obda.protege4 [10]: Unable to resolve 10.0: missing requirement [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.protege.editor.core)(version>=4.3.0)(!(version>=5.0.0)))
via DataStax JIRA by Zafar Khaydarov, 1 year ago
Unresolved constraint in bundle slf4j.api [10]: Unable to resolve 10.0: missing requirement [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.5.5))
via GitHub by Disassem
, 5 months ago
Unresolved constraint in bundle org.coode.dlquery [10]: Unable to resolve 10.0: missing requirement [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.protege.editor.core.ui.list)(version>=5.0.0))
org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.obr [10]: Unable to resolve 10.0: missing requirement [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.blueprint)(version>=1.0.0)(!(version>=2.0.0)))
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2045)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
at java.lang.Thread.run(Thread.java:744)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
14 more bugmates

Know the solutions? Share your knowledge to help other developers to debug faster.