Pattern selector

Most relevant patterns first. Most helpful ones displayed. Click here to show all.

  1. RegistryStrategyOSGI.createExecutableExtension() has thrown a LinkageError
    Unsorted
    1
    0
    0
  2. Class.newInstance() has thrown a LinkageError
    Java Runtime
    2
    0
    0

Your stack trace compared to the selected pattern

Jump to solutionsExpand frames
java.lang.LinkageError: loader constraint violation: when resolving overridden method "org.eclipse.mat.ui.editor.MultiPaneEditor.createPartControl(Lorg/eclipse/swt/widgets/Composite;)V" the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) of the current class, org/eclipse/mat/ui/editor/MultiPaneEditor, and its superclass loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader), have different Class objects for the type /eclipse/swt/widgets/Composite;)V used in the signature
3 matching frames hidden
    at java.lang.Class.newInstance(Class.java:345)
    at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:184)

External results for this pattern (1)

  1. Plug-in "org.eclipse.mat.ui" was unable to instantiate class "org.eclipse.mat.ui.snapshot.editor.HeapEditor".
    Show stack trace